What did Buildship do to "gradle tasks"?

issue-resolved

(Mark Linehan) #1

I imported an existing complex multi-project Gradle setup into Buildship, using Eclipse Mars and Gradle 2.12 and the latest Buildship from Eclipse Marketplace. This is on Windows 7.1.

In the Gradle Test view, I double-clicked on the top-level imported folder and ran all the tasks - successfully. Then I switched to a command-line interface and tried to “gradle tasks”, and got:

Execution failed for task ':tasks'.
> Could not determine the dependencies of task ':all'.

What did Buildship do to my project configuration and how can I fix it?

(I note that (a) “gradle tasks” always worked before; (b) there is no task named “all”.)


(Stefan Oehme) #2

Buildship doesn’t change anything about your project’s configuration. Can you please provide a reproducible example project on GitHub?


(Mark Linehan) #3

Unfortunately, this code is under a license restriction so I cannot make an example.

Regarding the statement “Buildship doesn’t change anything about your project’s configuration.” – it certainly sprinkled .setttings, .classpath, and .project files all over my project’s folders. But I don’t see how these could affect what gradle does when I run it outside of Eclipse.

What makes the task named “tasks” have a dependency on one named “all”? Neither of these are named anywhere in this multi-project build.

I tried comparing the current state of the project to a previous version, but so far, I can’t spot what’s changed.


(Mark Linehan) #4

Correction: as soon as I entered the previous reply, I found a task “all” in my build files. I commented it out, and the problem went away. My mistake, and my apologies.