Buildship does not run eclipseWtp task


(Joshua Street) #1

I’m trying to figure out why my multiproject, when imported into eclipse through buildship does not have the wst component nature attached like it should. I’m using 1.0.21 and gradle 2.14.1.

I’ve made sure every project applies the eclipse-wtp plugin by specifying it in the allprojects closure of the main build script. I could have sworn this worked at some point, now I’m stumped as to why its not.

What are the requirements for importing a multi-project project and having buildship run the eclipseWtp task?


How to perform specific tasks on buildship Refresh and Import
(Stefan Oehme) #2

This only works with Gradle 3.0+


(Joshua Street) #3

Something doesn’t make sense.

I could have sworn that the task was being called when I imported through my import task for oomph… and even when importing with buildship by itself. I thought this feature was dependent on just buildship 1.0.21 and not any specific gradle version? Is there something in the tooling that was added to 3.0 to allow it to run that task?


(Joshua Street) #4

I ran the eclipse task outside of buildship and lo and behold, I have a failing task thats run prior to it. Wonder if that is causing it to fail somehow?


(Stefan Oehme) #5

The eclipseWtp task was broken before 3.0, that’s why we don’t run it on earlier versions.


(Joshua Street) #6

I see. I have no clue how I managed to get eclipseWtp tasks to execute then. It does run properly with gradle 3.0+.

Looks like I will have to push for gradle to be upgraded…