Gradle's ant dependency needs to be updated to work with Java 8. Ant will report "Invalid Constant Pool entry Type 18" at some times


(Bair) #1

Hi guys,

We are using Gradle 1.4 and running into this issue: https://issues.apache.org/bugzilla/show_bug.cgi?id=54090. This was fixed in Ant 1.9.0 (https://svn.apache.org/repos/asf/ant/core/trunk/WHATSNEW). The current ant version is 1.9.1. Before shipping 1.7, can you update the version of ant in use? Because we’re using Gradle on 1.8 projects, we’re running into this issue (and because we also use the “depend” feature). If this goes into 1.7 we will upgrade our build systems to use 1.7.

Thanks Richard


(Peter Niederwieser) #2

Thanks for letting us know. We can’t update the Ant version for Gradle 1.7 (which is already in RC phase), but possibly for 1.8.


(Bair) #3

When is 1.8 expected?


(Peter Niederwieser) #4

Our release cycle is approximately 8 weeks. Or you can choose to use a nightly build.