Can't publish griffon plugins to portal

plugins

(Andres Almiray) #1

Using Gradle 2.13 and plugin-publish-plugin:0.9.3 (can’t use 0.9.4 => Can’t publish gradle plugin) I get the following exception

Caused by: java.lang.RuntimeException: Failed to post to server.
Server responded with:
The user does not have permission to create a new plugin with ID: org.codehaus.griffon.griffon
    at com.gradle.publish.ResponseUtil.assertValidResponse(ResponseUtil.java:17)
    at com.gradle.publish.OAuthHttpClient.send(OAuthHttpClient.java:78)
    at com.gradle.publish.PublishTask.doSignedPost(PublishTask.java:294)
    at com.gradle.publish.PublishTask.publishToPortal(PublishTask.java:177)
    at com.gradle.publish.PublishTask.publish(PublishTask.java:57)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.gradle.internal.reflect.JavaMethod.invoke(JavaMethod.java:75)
    at org.gradle.api.internal.project.taskfactory.AnnotationProcessingTaskFactory$StandardTaskAction.doExecute(AnnotationProcessingTaskFactory.java:228)
    at org.gradle.api.internal.project.taskfactory.AnnotationProcessingTaskFactory$StandardTaskAction.execute(AnnotationProcessingTaskFactory.java:221)
    at org.gradle.api.internal.project.taskfactory.AnnotationProcessingTaskFactory$StandardTaskAction.execute(AnnotationProcessingTaskFactory.java:210)
    at org.gradle.api.internal.AbstractTask$TaskActionWrapper.execute(AbstractTask.java:585)
    at org.gradle.api.internal.AbstractTask$TaskActionWrapper.execute(AbstractTask.java:568)
    at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeAction(ExecuteActionsTaskExecuter.java:80)
    at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:61)
    ... 71 more

There’s no additional indication on why there’s no access allowed or how to fix the problem. I’ve successfully posted a new release of the stats-gradle-plugin using the instructions laid out at the Plugin Portal, I’m pretty sure my account/API KEY worked in the past. Any clues on how to fix this would be greatly appreciated.


(Rus) #2

Was this plugin previously published via Bintray? You may need to reclaim it first.


(Andres Almiray) #3

So far the plugin has been published to Bintray since version 2.0.0 but did not make it to the previous iteration of the Gradle Plugin Portal, thus there’s nothing to claim at the moment :’(


(Rus) #4

We don’t have you as the owner of this plugin and that’s causing your publishing problem. I’m looking into this and will post back as soon as possible.

Were your other plugins also not in the previous iteration of the Plugin Portal?


(Andres Almiray) #5

That’s correct, the other 5 plugins under my name were published to the previous Plugin Portal.

Is there a missing step in https://plugins.gradle.org/docs/submit ? I don’t see a section regarding additional access/permissions. OTOH could this stop be caused by the chosen plugin id (org.codehaus.griffon.griffon). Please note that there’s a second Griffon plugin named org.codehaus.griffon.griffon-build.


(Rus) #6

You should be able to reclaim this plugin now and then publish as normal. Can you confirm that you can now see this plugin on the “Reclaim” tab of your profile page?


(Andres Almiray) #7

Thank you, it works now :smile:
However I’m missing access to the second Griffon plugin identified by org.codehaus.griffon.griffon-build. Could you help me with this one too? Thanks.


(Rus) #8

Np. Should be available for reclaim now.


(Andres Almiray) #9

Thank you again :smile:

I’m thinking in re-releasing similar plugins for Basilisk already available at Bintray under org.kordamp.basilisk.basilisk and org.kordamp.basilisk.basilisk-build. Would we have to follow the same procedure to reclaim those plugins?


(Rus) #10

I don’t see entries in the Plugin Portal for those plugins so I don’t think so. The other plugins had entries but no owner which caused the publishing problem.

Post back here if you get any problems though and I’ll get them sorted.


(Andres Almiray) #11

Fair enough, thank you for checking. I was preemptively getting ready for the upcoming release.
Will update this post in case any errors appeared during publication.