No permissions to upload plugin


We are trying to publish new plugin in plugin portal using com.gradle.plugin-publish, but it fails with following error:

The user 'xxx' does not have write permissions to:'

I am sure both key and secret are valid. I see no section in plugin portal or guide that would tell me how to allocate namespace for new plugin. The weird part is, we already have other plugin published in ( - but it was published using bintray and then reclaimed when new portal was released.

Any suggestions on how to solve this problem?

Thanks for bringing this to our attention, looking into it.

Would you mind disambiguating your ‘xxx’ parameters? I don’t really see why you shouldn’t be able to write to ‘’ so long as said plugin doesn’t already exist or you are its owner.

After investigating a bit, it looks as if your plugins are owned by andrejczyn. Is he an Allegro employee? I’m guessing these plugins should be moved to the allegro user.


I tried to release the plugin using my private account, but I receive a message that I am not the owner of and release fail. Now I do not see any information about plugin in my profile.

@arve_knudsen can you remove this plugin. After we will try to publish again using the allegro user.

@andrejczyn Can you please try publishing it again as allegro?

Unfortunately fail. The same problem :frowning:

Hmmm… Checking what the cause might be.

@andrejczyn To make sure, can you please type out the whole error, and not censor parts out with ‘xxx’?

Now I see that message is little different:

26-May-2015 21:10:47 Server responded with:
26-May-2015 21:10:47 The user does not have permission to create a new plugin with ID:

Thanks, would you mind please trying again?

1 Like

Perfect!! Now it works. Thanks :slight_smile:

1 Like

Great to hear that it’s solved!