Gradle Publish Plugin keys not working


(Stewart Bryson) #1

My API keys for the Plugin Portal stopped working all of the sudden. I just get:

Execution failed for task ':publishPlugins'.
> Unauthorized!
Login from command line using:
  gradle login
or login and download user API keys on:
  https://plugins.gradle.org/user/login

I’m not sure if there is somewhere more “official” to raise this issue?


Cannot publish my plugin on Gradle Plugins Repository (unauthorized)
(Concurrent Systems) #2

Same issue here as of a few hours ago. The key is being sent correctly, but I get an Unauthorized response.


(Rus) #3

Thanks for reporting. I’ll take a look and post back here with any info.


(Rus) #4

Would you mind trying again so I can get some more information? TIA


(Stewart Bryson) #5

I’m getting the same result.


(Rus) #6

Would you mind trying once more? I expect it to fail but hopefully will get some better information in our logs.


(Concurrent Systems) #7

Tried again

With debugging enabled I see {"failed":true,"errorMessage":"Signature does not match. Signature base: ..."}.

Full output (with some information blanked out)

> Task :publishPlugins
16:33:50.953 [DEBUG] [org.gradle.internal.progress.DefaultBuildOperationExecutor] Build operation 'Task :publishPlugins' started
16:33:50.953 [DEBUG] [org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceTaskExecuter] Starting to execute task ':publishPlugins'
16:33:50.953 [INFO] [org.gradle.api.internal.tasks.execution.ResolveTaskArtifactStateTaskExecuter] Putting task artifact state for task ':publishPlugins' into context took 0.0 secs.
16:33:50.953 [DEBUG] [org.gradle.api.internal.tasks.execution.SkipUpToDateTaskExecuter] Determining if task ':publishPlugins' is up-to-date
16:33:50.953 [INFO] [org.gradle.api.internal.tasks.execution.SkipUpToDateTaskExecuter] Executing task ':publishPlugins' (up-to-date check took 0.0 secs) due to:
  Task has not declared any outputs.
16:33:50.953 [DEBUG] [org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter] Executing actions for task ':publishPlugins'.
16:33:50.953 [DEBUG] [org.gradle.internal.progress.DefaultBuildOperationExecutor] Build operation 'Execute task action 1/1 for :publishPlugins' started
16:33:50.958 [LIFECYCLE] [com.gradle.publish.PublishTask] Publishing plugin ga.csys.tooling.gradle.pkssh-mavenrepo-gradle version 1.0.902
16:33:50.996 [DEBUG] [sun.net.www.protocol.http.HttpURLConnection] sun.net.www.MessageHeader@469210bf8 pairs: {POST /api/v1/publish/versions/new/ga.csys.tooling.gradle.pkssh-mavenrepo-gradle HTTP/1.1: null}{Content-Type: application/json; charset=utf-8}{Authorization: OAuth oauth_consumer_key="gradle", oauth_nonce="5826540798073376561", oauth_signature="VufK...", oauth_signature_method="HMAC-SHA1", oauth_timestamp="1501511630", oauth_token="...", oauth_version="1.0"}{User-Agent: Java/1.8.0_131}{Host: plugins.gradle.org}{Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2}{Connection: keep-alive}{Content-Length: 1078}
16:33:51.989 [DEBUG] [sun.net.www.protocol.http.HttpURLConnection] sun.net.www.MessageHeader@1396e9d39 pairs: {null: HTTP/1.1 401 Unauthorized}{Date: Mon, 31 Jul 2017 14:33:51 GMT}{Content-Type: application/json}{Transfer-Encoding: chunked}{Connection: keep-alive}{Set-Cookie: __cfduid=d320a70f50fd03139f62d0f59879d2cac1501511631; expires=Tue, 31-Jul-18 14:33:51 GMT; path=/; domain=.gradle.org; HttpOnly}{Via: 1.1 vegur}{Server: cloudflare-nginx}{CF-RAY: 3871466db89447f9-JNB}
16:33:51.990 [DEBUG] [com.gradle.publish.OAuthHttpClient] Signed post response with code: 401 was: {"failed":true,"errorMessage":"Signature does not match. Signature base: POST\u0026http%3A%2F%2Fplugins.gradle.org%2Fapi%2Fv1%2Fpublish%2Fversions%2Fnew%2Fga.csys.tooling.gradle.pkssh-mavenrepo-gradle\u0026oauth_consumer_key%3Dgradle%26oauth_nonce%3D5826540798073376561%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1501511630%26oauth_token%3D...%26oauth_version%3D1.0"}
16:33:51.991 [DEBUG] [org.gradle.internal.progress.DefaultBuildOperationExecutor] Completing Build operation 'Execute task action 1/1 for :publishPlugins'
16:33:51.991 [DEBUG] [org.gradle.api.internal.tasks.execution.ResolveTaskArtifactStateTaskExecuter] Removed task artifact state for {} from context.

(Stewart Bryson) #8

I ran again as well with the same result.


(Rus) #9

Thanks both. I will get back to you as soon as possible.


(Renato Athaydes) #10

Having the same problem… I posted another topic about this (didn’t see this one at first): Cannot publish my plugin on Gradle Plugins Repository (unauthorized)

Will this be fixed today?


(mat) #11

I tried also to publish a new version of a plugin and I got the same error on Travis as well on the command line. This stops the progress of our on going updates on plugins.

When will the problem be fixed? And how do I know it’s working again?


(Rus) #12

We are working to get this resolved as soon as possible. Please subscribe to the incident on our status page to keep informed of updates https://status.gradle.com/. We will also post back on this thread.


(Tom Dunstan) #13

Hi all

The issue has been resolved.

Yesterday we rolled out an update that included an updated version of a particular component, and while this passed our automated testing, it caused issues running in the production portal. We’ve beefed up our pre-release testing to catch this type of error in the future.

Apologies for the outage. Please try to publish your new plugin versions again.

Regards

Tom


(Concurrent Systems) #14

Thanks Tom,
I can confirm that the plugin portal is now working as expected again.


(Renato Athaydes) #15

Yep, it’s working again. Thanks!


(Stewart Bryson) #16

Working for me as well. Thanks for fixing, and for the work on ensuring future availability.