"Your build scan could not be displayed." what does this mean?

A few Apache Beam community members have mentioned that they get the same error when using --scan locally or when run via Jenkins.

Here is an example link:

Is this a temporary issue or do we need to upgrade our version of Gradle that we use?

1 Like

Hi there!

Thanks for reporting this, it doesn’t look like a temporary issue, and we are investigating why the scan is failing to render :+1:

In the mean time, can you try the build scan plugin 2.4.2? I think you’re on 2.4 and there were some fixes in 2.4.2 for remote script handling



I tried with the 2.4.2 plugin but still receive a failure, here is the new link https://scans.gradle.com/s/xm4nfnkg425ky

Thanks for trying… We will investigate.

I looked into the providing scan. That issue seems to be on the plugin side unfortunately. Is it possible for you to provide a reproducable example build we can use locally to narrow down the root cause?

at luke. from having a deeper look my initial hunch is that this is related to the spotless plugin you’re using. Would you mind trying your build without this plugin being applied? As said a reproducable example bulid would be golden for use narrowing down this issue quickly.

thanks again!


git clone https://github.com/apache/beam.git
cd beam
git checkout 04dc3c3b14ab780e9736d5f769c6bf2a27a390bb
./gradlew compileJava --scan

I tried 3.24.3 (latest) and 3.17.0 (previous version we were using) of the spotless plugin and both of them had the same error.

I created https://github.com/lukecwik/incubator-beam/commit/1f026c9b94e3f8afc0cd472350b77c1eeef30a83 which removed spotless and I was able to successfully view the build scan https://scans.gradle.com/s/665zarmdoixh6

Any suggestions on how to keep the spotless plugin and also have build scans working?

Hi Lukasz!

Thanks for reporting this. It’s caused by the spotless plugin resolving build script configurations in an unexpected place, which is why removing spotless from your build fixes the issue.

We will include a fix to handle the unexpected data more gracefully in the next version of Gradle Enterprise and will of course update scans.gradle.com when the fix is available.

In the meantime your options are to remove spotless as you have done here, or downgrade the build scan plugin to version 2.3. The latter means that you won’t collect / view the new dependency data that 2.4 enables, but it also won’t fall over before the bug is fixed.

Hope that helps!



Hi Lukasz,

FYI the fix to handle the unexpected data more gracefully is now released to scans.gradle.com.


Hi, I just wanted to mention that I am seeing the same issue as well today using build scan plugin 2.4.2. I also saw it on a few other versions, 2.3, 2.0.2.

I can give removing spotless a try as well.

Hi @ajamato,

We have limits in place at scans.gradle.com regarding:

  • the total size of the build scan
  • individual parts of this data

When such limits are reached, scans.gradle.com rejects the build scan, and you see ‘Your build scan could not be displayed’ when you try to access the build scan.
We plan to improve the user experience here, by providing more information when that happens, but I can’t commit to any date yet.

Please note that when using a licensed Gradle Enterprise instance, these limits are configurable to suit your needs.

Also, we optimized the storage of some captured build scan data in recent Gradle Enterprise Gradle plugin versions, and some builds that were exhibiting these symptoms with older version of the plugin will now work fine. Could you upgrade to a more recent version of the plugin and try ?
If it still fails, you can also give me the build scan URL and I will look exactly which type of data is causing the problem, to give you more context.

It is also possible that this message is shown when there is a genuine error processing the build scan data, but I can’t know for sure unless you give me a build scan URL.