Visual Studio plugin odd behavior on Gradle 3.3


(Adrian Lis) #1

I believe something has been broken in Gradle 3.3 in regards to project generation.

Whenever I run Visual Studio generation tasks on my multiproject, they are not marked as Up-To-Date even if they were already run and generated the vcxproj and sln files and nothing else has changed. The problem is that the files are not removed after re-running the task but actually are appended, leading to broken projects if I run the project generation task more than once (for example after running 3 times I get each line in vcxproj duplicated 3 times as well)

Could someone verify if this is actually a bug or am I doing something strange that would cause it to break in gradle 3.3 ?

Edit: I have checked it on 3.2.1 - it has exactly the same problem. Then I checked 2.14.1 and it works fine. Rerunning the task just re-generates the files without appending the same contents over and over again. So the question is - is vs plugin bugged in 3.X and should I file a bug report at github or is there something odd in my usage?


(Daniel Lacasse) #2

Thanks Adrian for reporting this. Could you help us a bit and try your scenario on Gradle 3.0 as well as 3.1? That would be really helpful for us.


(Adrian Lis) #3

@Daniel_L Sorry about a really late reply, I totaly forgot about it since I wasn’t doing anything related lately.

It is a problem on 3.1. I think it started misbehaving since initial 3.X release. Also what I see now is that there is an issue that has been in your github issues page for quite some time: https://github.com/gradle/gradle/issues/790 so my bad I missed it.

What I can tell you is that I can verify that this simply does not work as expected and as described in the linked bug.


(Daniel Lacasse) #4

Thanks I will see if I can find where this was introduces.