Unable to upgrade buildship


(Rinaldo Di Giorgio) #1

Don’t know if it is a bug yet. Thought I would ask here:

Unable to upgrade the plugin – getting the following.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.gradleware.tooling.client,0.19.4.v20171108133209
No repository found containing: osgi.bundle,com.gradleware.tooling.model,0.19.4.v20171108133209
No repository found containing: osgi.bundle,com.gradleware.tooling.utils,0.19.4.v20171108133209
No repository found containing: osgi.bundle,org.eclipse.buildship.branding,2.2.0.v20171211-1404
No repository found containing: osgi.bundle,org.eclipse.buildship.core,2.2.0.v20171211-1404
No repository found containing: osgi.bundle,org.eclipse.buildship.stsmigration,2.2.0.v20171211-1404
No repository found containing: osgi.bundle,org.eclipse.buildship.ui,2.2.0.v20171211-1404
No repository found containing: osgi.bundle,org.gradle.toolingapi,4.3.0.v20171108133209
No repository found containing: org.eclipse.update.feature,org.eclipse.buildship,2.2.0.v20171211-1404


(Donát Csikós) #2

Thanks for the report. In fact, this has already been reported. The problem is sporadic, and most probably not Buildship specific (see the related Bugzilla issue).

The Eclipse Marketplace is known to be more stable, you can try updating from there.