Still unable to update Buildship


(davidmichaelkarr) #1

For a long time now, I’ve been struggling with updating Buildship from the old 1.0.21 version to the latest. Ok, well, perhaps “struggling” isn’t quite right. I’ve tried several times, it fails each time, and I’ve briefly tried to pursue resources to get answers.

I’m running Eclipse Neon.2. I have version “1.0.21.v20161010-1640” of Buildship. The update site I’m using is “http://download.eclipse.org/buildship/updates/e46/releases/2.x”.

When I “Check for Updates”, the first page I see is “Update Details”, “Review and confirm the updates”. It shows me updates for the following:

  • Buildship: 2.0.1
  • Groovy-Eclipse M2E Integration: 2.9.2
  • JDT Core Patch for Groovy-Eclipse plugin for Eclipse 4.6: 2.9.2
  • Oomph Setup: 1.7.0

(Curiously, I’m not seeing a page that allows me to select which ones to update, this page is just confirming updates for all of these.)

When I click “Finish”, it gives me this:
An error occurred while collecting items to be installed
session context was:(profile=…eclipse_java-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.gradleware.tooling.client,0.18.0.v20170220163122
No repository found containing: osgi.bundle,com.gradleware.tooling.model,0.18.0.v20170220163122
No repository found containing: osgi.bundle,com.gradleware.tooling.utils,0.18.0.v20170220163122
No repository found containing: osgi.bundle,org.eclipse.buildship.branding,2.0.1.v20170302-1039
No repository found containing: osgi.bundle,org.eclipse.buildship.core,2.0.1.v20170302-1039
No repository found containing: osgi.bundle,org.eclipse.buildship.stsmigration,2.0.1.v20170302-1039
No repository found containing: osgi.bundle,org.eclipse.buildship.ui,2.0.1.v20170302-1039
No repository found containing: osgi.bundle,org.gradle.toolingapi,3.4.0.v20170220163122
No repository found containing: org.eclipse.update.feature,org.eclipse.buildship,2.0.1.v20170302-1039


(Thad Humphries) #2

I had to go through the Help -> Eclipse Marketplace… menu option; Help -> Check for updates always failed. See Buildship 2.0.1 is now available


(davidmichaelkarr) #3

It appears that I was able to finally get this to work. I had to first uninstall the 1.0.21 version, and then install the 2.0.1 version. I thought I had tried this before, but it appeared to work this time.