2.0 release update site not working today

issue-resolved
buildship
eclipse

(Staffan Forsell) #1

I installed Eclipse Neon today and immediately tried to update Buildship to 2.0, since the installer only installs Buildship 1.0.

  1. First of all I get an error when using the regular update site (Buildship - http://download.eclipse.org/buildship/updates/e46/releases/2.x)

An error occurred while collecting items to be installed
session context was:(profile=_home_stalle_eclipse_java-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.buildship.branding,2.0.0.v20170111-1029
No repository found containing: osgi.bundle,org.eclipse.buildship.core,2.0.0.v20170111-1029
No repository found containing: osgi.bundle,org.eclipse.buildship.stsmigration,2.0.0.v20170111-1029
No repository found containing: osgi.bundle,org.eclipse.buildship.ui,2.0.0.v20170111-1029
No repository found containing: org.eclipse.update.feature,org.eclipse.buildship,2.0.0.v20170111-1029

I got around it by using the milestones repo which worked. But the releases one still does not work for me.

  1. The other minor error is that if you go to the Eclipse Marketplace directly after Neon install, it shows “Buildship 2.0” as installed, although currently installed version is 1.0.xx .

(Donát Csikós) #2

Hi! I’m trying to investigate your problem, but things look fine to me. Here’s what I’ve done:

  1. I installed Eclipse Neon for Java Developers with the Oomph Eclipse installer in basic mode. The installation contained Buildship 1.0.21 as expected.
  2. When searched for updates, none was discovered.
  3. I tried to install Buildship 2.0 from the marketplace. The UI says Buildship is already installed, but that’s only a wrong label. If you click on ‘installed’ button, it will actually do the upgrade. I tried and it worked for me.

So, how did you end up with an automatic - and failing - update? Did you use a different Eclipse package? Anything else that might be specific to your environment?


(Staffan Forsell) #3

I just pulled the installed from eclipse, installed eclipse standard java (same as you) and went to marketplace and selected “check for updates”, it finds Buildship 2.0.0.v20170111-1029 but when I try to install it, it fails with the previous error.
I tried using mobile hot spot but I get the same error message.
I don’t really know any way to debug this more…


(Donát Csikós) #4

I have a quick suggestion: can you please try to uninstall the existing Buildship version and then install the latest release from the marketplace?


(Staffan Forsell) #5

Hold the presses!!
Just tried again… when pressing disabled button in marketplace, it changes from install->update and pressing it again actually makes the installation succeed.
I actually never pressed the install button in marketplace last time. I just went into marketplace and then closed marketplace after having serached for buildship and then used the normal “check for updates” in the help menu. That produced the error even though the update path was set correctly.


(Donát Csikós) #6

I’m glad to hear that you found the solution.


(Staffan Forsell) #7

Removed my installation and ~/.eclipse and retried a couple of times using different ways and I could not reproduce this time. Which is strange because I reproduced it in my friends machine a couple of hours ago…
Well chalk this up to some strange update server error I guess…
Anyhow, now it seems to work. :confused: