Terminal problems


(steve) #1
------------------------------------------------------------
Gradle 3.1
------------------------------------------------------------

Build time:   2016-09-19 10:53:53 UTC
Revision:     13f38ba699afd86d7cdc4ed8fd7dd3960c0b1f97

Groovy:       2.4.7
Ant:          Apache Ant(TM) version 1.9.6 compiled on June 29 2015
JVM:          1.8.0_40 (Oracle Corporation 25.40-b25)
OS:           Linux 4.8.4-200.fc24.x86_64 amd64

Is this a regression? If yes, which version of Gradle do you know it last worked for?

It worked prior to upgrading to Fedora 24. It worked on both 22 and 23 prior.

The specific project is not relevant. It happens on all of them. But the Hibernate ORM build is one example.

Again, not relevant. But the Hibernate ORM build is one example.


Since upgrade to Fedora 24 running Gradle in a GNOME Terminal (the standard terminal app) has undergone a few noticeable changes that are certainly undesirable and I’d argue are regressions:

  1. Gradle output is no longer colored. Everything output from Gradle is black text
  2. Ctrl+C no longer stops the Gradle process
  3. Gradle used to output progress through tasks like test (e.e. - Executing test 39 of 4049, 12 skipped.) That no longer occurs.

Chris from the Hibernate team looked into this and found a workaround : http://stackoverflow.com/questions/38667393/upgraded-fedora-24-gradle-status-text-does-not-show

To be honest I have no idea if this is a Gradle bug or a problem in Fedora. But I’d lean towards it being a problem in Gradle since the OS is well within its rights to upgrade that lib


(Sterling Greene) #2

Have you tried installing ncurses-compat-libs on the Fedora box? I think the native-platform library we use is built against ncurses 5.x.


(steve) #3

I have done nothing “extra” on this box; I have waited to try and help
y’all try out solutions. Would you like me to try installing
ncurses-compat-libs?


(Marcin Zajączkowski) #4

It helped on my Fedora 25 Beta box. However, it would be good to see at least a warning explaining that Gradle output is limited due to some native issues.


(Sterling Greene) #5

I think @Marcin’s confirmation is good enough. It’s a different kind of workaround than the stackoverflow post you linked to.

I’ve raised issues in both projects (Gradle and our native-platform lib).


(steve) #6

I went ahead and installed ncurses-compat-libs and can confirm it resolves
the problem.


(Sterling Greene) #7

We’ve put some fixes into 3.3, so when the next RC is out (~in a month), please take a look. Thanks!