Sonarqube doesn't work


When I run >gradle sonarqube, I am getting below error.

C:\abc\ws_2021_12\search>gradle sonarqube

FAILURE: Build failed with an exception.

* Where:
Build file 'C:\abc\ws_2021_12\search\build.gradle' line: 9

* What went wrong:
Plugin [id: 'org.sonarqube', version: '3.3'] was not found in any of the following sources:

- Gradle Core Plugins (plugin is not in 'org.gradle' namespace)
- Plugin Repositories (could not resolve plugin artifact 'org.sonarqube:org.sonarqube.gradle.plugin:3.3')
Searched in the following repositories:
  Gradle Central Plugin Repository

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.


Below is tech stack I am using.

Springboot (2.6.3), Gradle Gradle (7.3.3), java 17 (Correto), sonarqube-,


I have added id “org.sonarqube” version "3.3"

repositories {

I tried different ways but exception doesn’t go away. Could you please help me out.

There’s nothing wrong with applying the org.sonarqube plugin using:

plugins {
    id 'org.sonarqube' version '3.3'

The error indicates that Gradle tried to resolve 'org.sonarqube:org.sonarqube.gradle.plugin:3.3' from the plugin portal, which is exactly what it should do. This is most likely a connectivity issue (which you might need to further diagnose), not something wrong inyour build.gradle file.

1 Like