Process 'command 'C:\Java\jdk1.8.0_151\bin\javadoc.exe'' finished with non-zero exit value 1


(XuXiaLing) #1

scans url:https://scans.gradle.com/s/mxo55hle53yvc/

The following is build.gradle

plugins {
id ‘java’

}

group ‘org.springframework’
version ‘5.1.0.BUILD-SNAPSHOT’

sourceCompatibility = 1.8

repositories {
mavenCentral()
}

dependencies {
testCompile group: ‘junit’, name: ‘junit’, version: ‘4.12’
compile(project(":spring-beans"))
compile(project(":spring-context"))
compile(project(":spring-instrument"))

}

What can i do to avoid that problem?

Thanks for any help.

JeffreyXu


(Chris Doré) #2

Did you look at the contents of the generated javadoc options file for anything that looks incorrect?

C:\Java\AliYun_GitHub\spring-framework\spring-mytest\build\tmp\javadoc\javadoc.options


(XuXiaLing) #3

I could’t find incorrect in the javadoc.options file.

I modified several places in the root build.gradle。

1、Added failOnError = false .
javadoc {
description = “Generates project-level javadoc for use in -javadoc jar”

	options.memberLevel = org.gradle.external.javadoc.JavadocMemberLevel.PROTECTED
	options.author = true
	options.header = project.name
	options.use = true
    options.encoding("UTF-8")
	options.links(project.ext.javadocLinks)
	options.addStringOption("Xdoclint:none", "-quiet")
    failOnError = false
 }

2、Annotated all code related to checkstyle. e.g:
// checkstyle(“io.spring.javaformat:spring-javaformat-checkstyle:0.0.5”)

   /*
     checkstyle {
	toolVersion = "8.10.1"
	configDir = rootProject.file("src/checkstyle")
}
*/
 //apply plugin: "checkstyle"

There was no error in code compilation.

Thanks!