Error building Javadoc

gradle version 8.1

stack Untitled - Paste Site ::

scan Build Scan™ | Gradle Cloud Services

javadoc.options - View paste jvSmo

Is there a question hidden somewhere?
Especially a Gradle related one?
Your JavaDoc annotations have many warnings and also 7 errors as your output tells you.
So the JavaDoc tool fails to finish.
Fix them and go on.

I can’t know what the error is, those error log are all error code, I’ve used UTF-8 encoding but nothing work.Meanwhile javadoc successfully generated, but task execution fails, I use isFailOnError = false then javadoc product exists

the javadoc tasks have garbled code, which is a hidden problem.

I’m sorry, but I don’t really understand what your are saying. The warnings and errors are all listed in the console output. I just cannot tell you which are the 7 errors because the output is in Chinese, which I don’t understand and the build scan obviously didn’t record properly. But I’d expect it to be properly readable in your console.

Sorry, my English is not good.
There are errors in the decoding of these logs, do you know how to fix it?

What you underlined last should be the warnings, above - the 7 - should be the errors.
I don’t know about the build scan, I reported that at Chinese output in build scan garbled · Issue #25211 · gradle/gradle · GitHub, but I’d expect that if you look at your actual console output instead of the build scan, that you then see the properly encoded output.

Thank you for your answer, but it’s not just in scan, the console output also has the same error.

Try executing the JavaDoc command itself in the console and see whether it still has the same issue, then Gradle is out of the loop.

Maybe you need a different Java, or maybe your console is configured wrongly. As a work-around you could probably set your locale to English to get English messages.

Thank you, after change the system language to English there are no more error log.Already solved the javadoc error

1 Like