Build wrong in /subprojects/docs/build.gradle

I’m tring to build the gradle-8.1.1-src for learning. But when I use the command “./gradlew assemble” I meet the problem:
Also, I’ve added a brief build.gradle file in the root ,and I’d like to know if there’s any error:

allprojects {
task clean(type: Delete) {
    delete rootProject.buildDir

You should probably not add any options to the build.
Besides that allprojects { ... } is highly discouraged anyway,
by doing tasks.withType(...).all { ... } you prevent task configuration avoidance and cause all tasks of that type to be eagerly created and configured.
The :docs.javadocAll task seems to not be properly configured yet to be realized.
If you use tasks.withType(...).configureEach { ... } instead, it will probably work.

Besides that, assemble is most probably not what you want.
Have a look at the file.

Thanks for your reply. I’ll try your advice.
Because I met the problem earlier that “Javadoc generation failed. Generated Javadoc options file (useful for troubleshooting)” , so I added the option by other’s advice.
But I’m glad to say that the problem get solved successfully. It have troubled me for a week. I’m really grateful for your solution.
However, I meet a new error in executing stage:

Never seen that. Maybe try to ./gradlew --stop the daemon and try again.
Looks to me like something is corrupt within the running daemon without having a closer look.

OK the first failure disappear. Thanks. But the second "Configuration cache problems found in this build."still exist, detailed question just like:

Again, read the

Configuration cache enabled by default

The build of Gradle enables the configuration cache by default as a dogfooding experiment.

Most tasks that are used to build Gradle support the configuration cache, but some don’t. For example, building the documentation currently requires you to disable the configuration cache.

To disable the configuration cache, run the build with --no-configuration-cache.

Tasks known to have problems are listed in the build logic. You can find this list at:


If you discover a task that doesn’t work with the configuration but it not in this list, please add it.

For more information on the configuration cache, see the user manual.

All problems get solved. Thanks for your help :wink:

1 Like