New website for gradle.org


(Hans Dockter) #1

We just published a completely revamped gradle.org website. We are extremely happy about that. We think the website is first of all more user friendly and information rich. But its design also reflects much better the qualities we see in Gradle.

Happy Holidays


(Andrew Bayer) #2

FYI, all your old links (http://gradle.org/standard_plugins, e.g.) now go to “Page Not Found”, which, given Google presence, bookmarks, etc, is a bit of a pain. =)


#3

We were aware of this issue, and are currently working on getting known links setup with redirects: the only you reference is not working.

Thanks for taking the time to bring it up. If you find more, please let us know.


#4

We were aware of this issue, and are currently working on getting known links setup with redirects: the only you reference is not working.

Thanks for taking the time to bring it up. If you find more, please let us know.


(Saager Mhatre) #5

The links to the documentation in the box on the right of the page seem broken too.


(Bogomil Tsekov) #6

Hi gradlers,

Your new design is very cool and I like it, but it is a real mess under IE9. Please correnct this.

Regards, Bogomil


(Luke Daley) #7

Hi Bogomil,

It looks fine in IE9 to me. Can you please attach a screenshot of what you are seeing.


(Bogomil Tsekov) #8


(Bogomil Tsekov) #9

Sure, Luke, It is attached.

It’s been a while since we’ve met at Software AG Bulgaria training.


(Luke Daley) #10

You’re getting a weird version of the mobile layout because your browser is responding incorrectly to the media queries in the stylesheet.

The query is:

@media handheld and (max-width: 480px), screen and (max-device-width: 480px), screen and (max-width: 500px)

I notice that you are using a Software AG version of IE9. I don’t see the same when using a vanilla IE9 download so there must be some configuration in your corporate version that is causing this. I’ll do some research to see if this is a known problem with badged versions.

Are you able to try with a vanilla IE9 download?


(Luke Daley) #11

Ah, you are using IE9 in IE8 emulation mode which doesn’t support media queries at all. I’ll get that sorted out…


(Luke Daley) #12

Just pushed a fixed version. Thanks for reporting this Bogomil :slight_smile:

I hope that Gradle has been working well for you since the training session!


(Bogomil Tsekov) #13

Now everything looks fine.


(Bogomil Tsekov) #14

We’re still proud gradle users! You are doing fantastic job!


(robert.j.lloyd) #15

I’m getting a 404 error on the http://www.gradle.org homepage, this morning. Looks like it’s missing the /layout.php.


(robert.j.lloyd) #16

It’s working now, thanks!