Kotlin android extensions plugin from nowhere

I am compiling a project and a totally unrelated change in a dependency cause the compilation to fail with this message:

exception: error: the Android extensions ('kotlin-android-extensions') compiler plugin is no longer supported. Please use kotlin parcelize and view binding. More information: https://goo.gle/kotlin-android-extensions-deprecation
Errors were stored into /Users/ftomassetti/repos/kolasu-java-langmodule/.gradle/kotlin/errors/errors-1693911101221.log

My problem is that I cannot find any reference to the kotlin-android-extensions compiler plugin, so I wonder where that comes from.

I also tried publishing a build scan, in case it helps: Build ScanĀ® | Gradle Cloud Services