I want to use Gradle 1.12, but it asks me to use 1.10 o_O

I want to Gradle 1.12. I updated my “gradle-wrapper.properties” like follow:






Then I ran “gradlew --info”, after the Gradle 1.12. is donwloaded, I got the following error while building:

./gradlew --info

Starting Build

Settings evaluated using settings file ‘C:\Users\shend\IdeaProjects\MyApplication2\settings.gradle’.

Projects loaded. Root project using build file ‘C:\Users\shend\IdeaProjects\MyApplication2\build.gradle’.

Included projects: [root project ‘MyApplication2’, project ‘:app’]

Evaluating root project ‘MyApplication2’ using build file ‘C:\Users\shend\IdeaProjects\MyApplication2\build.gradle’.

Compiling build file ‘C:\Users\shend\IdeaProjects\MyApplication2\build.gradle’ using StatementExtractingScriptTransformer.

Compiling build file ‘C:\Users\shend\IdeaProjects\MyApplication2\build.gradle’ using BuildScriptTransformer.

Evaluating project ‘:app’ using build file ‘C:\Users\shend\IdeaProjects\MyApplication2\app\build.gradle’.

FAILURE: Build failed with an exception.

  • Where:

Build file ‘C:\Users\shend\IdeaProjects\MyApplication2\app\build.gradle’ line: 14

  • What went wrong:

A problem occurred evaluating project ‘:app’.

Gradle version 1.10 is required. Current version is 1.12. If using the gradle wrapper, try editing the distributionUrl in C:\Users\shend\IdeaProjects\MyApplication2\gradle\wrapper\gradle-wrapper.properties to gradle-1.10-all.zip

  • Try:

Run with --stacktrace option to get the stack trace. Run with --debug option to get more log output.


My build.gradle file looks like:

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {

repositories {



dependencies {

classpath ‘com.android.tools.build:gradle:0.9.+’



allprojects {

repositories {




The Android plugin is currently bound to a particular Gradle version. So unless/until there is a newer version of the Android plugin, you’ll have to stick to 1.10.


Thank you for this tip :slight_smile:

errr…wait! I got the idea to use Gradle from here, which seems they can use the android plugin with Gradle 1.12. I have updated my ‘build.gradle’ as they instructed. Since the error is from Gradle, no from their plugin, I think it is apporiate to post here.

The error does come from the Android plugin. The build you linked to isn’t applying the Android plugin.

Note that they advertise to use Android plugin 0.10.1, whereas you are using 0.9.+. Perhaps 0.10.1 requires/supports Gradle 1.12.

Correct: Android plugin 0.10 support range of Gradle versions 1.10-1.12. The older 0.9 version was tied to Gradle 1.10.