How to override sonar runner version of sonar plugin?


(Martin) #1

Two questions:

How do I set a different sonar-runner lib version for the sonar plugin? Where would this dependency stored when using the gradle wrapper?

We tried to set up a different version in the buildScript section under depedencies but we’re not quite sure whether gradle took the right one.


(Peter Niederwieser) #2

You can’t - the sonar-runner lib isn’t designed for that. However, it is supposed to be reasonably forward- and backwards-compatible with Sonar versions.


(Christoph Kutzinski) #3

Thanks, (I’m a colleague of Martin) I have problems with running the sonar-runner on Jenkins: https://groups.google.com/forum/#!searchin/jenkinsci-users/Gradle|sort:date/jenkinsci-users/Vao-osDC-lg/sIct17MeJh8J and was hoping to fix this with using a newer sonar-runner lib. Do you have any idea, what is going wrong there? Seems no one on the Jenkins users list can help.


(Peter Niederwieser) #4

As far as I know, Sonar project names must not contain whitespace characters. Best ask the Sonar folks though.


(Christoph Kutzinski) #5

Thanks, quite obvious, now that you pointed to it, that the project name on Jenkins contains a space. How did I miss this… ?

I’ve removed the space and now it works. Thanks!