Sonar-runner (nighty build) missing dependency


i am trying to use the sonar-runner plugin in a multi-project build. Because of I’m using the latest nightly build.

I applied the plugin to the root project (as stated in the docs for multi-project builds). The root project itself does not contain any sources.

Problem is that when I run ‘gradlew sonarRunner’ it fails and gradle complains about a missing ‘org.codehaus.sonar.runner:sonar-runner-dist:2.3’ dependency.

When I run ‘gradle dependencies’ I get:

Root project

sonarRunner - The SonarRunner configuration to use to run analysis

— org.codehaus.sonar.runner:sonar-runner-dist:2.3 FAILED

How do I add the dependency?

There is no language plugin active in the root project so I tried:

dependencies {

sonarRunner ‘org.codehaus.sonar.runner:sonar-runner-dist:2.3’


// found 'sonarRunner’configuration by …

configurations.each { println “** ${}” }

This didn’t help. I also tried to add it as

buildscript {

repositories {



dependencies {

classpath ‘org.codehaus.sonar.runner:sonar-runner-dist:2.3’



But this didn’t help either.

Where is the trick ? :slight_smile:

Hello Martin,

have you declared a repository where the sonar-runner is resolved from (usually mavencentral)? Don’t mix it up with the repository in the buildscript block. you need one at root level:

apply plugin:'sonar-runner'

cheers, René

uh uh, stupid me :wink: Thanks.