Gradle Tasks view does not show Tasks in STS


(Run) #1

Hey guys,

I decided to upgrade to the latest version of Spring Tool Suite, and that included dropping Gradle STS for Buildship. However I am experiencing an issue.

My project has the Gradle “G” Icon in Package Explorer and its many subprojects.
When I open the tasks view there is a folder for each subproject.
However, when I expand the folder, nothing appears.

There appear to be no tasks that I can run so I cannot build. Am I missing some configuration step or something? I have tried:

  • Clicking the refresh button
  • Blowing away my project and workspace, starting fresh and doing a new import

But these have not worked.


(Stefan Oehme) #2

Hi,

could you provide a reproducible example project on GitHub and possibly a screenshot of the tasks view? That would really help narrow the problem down.

Cheers,
Stefan


(Run) #3

Here is the screenshot you requested: Folders without the “>” symbol to their left indicate folders I tried to open where I should see tasks. If I double click the folder I see a message in the console indicating:

To run a build, run gradle …

To see a list of available tasks, run gradle tasks

To see a list of command-line options, run gradle --help

BUILD SUCCESSFUL

Total time: 0.923 secs

I can run builds successfully from the command line and my individual tasks appeared when I previously used the STS Gradle plugin


(Run) #4

I’m working on something reproducible but that is a tougher task


(Stefan Oehme) #5

Can you try activating “Show Project Tasks” and “Show all Tasks” in the options of the task view? That might help narrow down the problem.