Gradle tasks tab in Eclipse: Could not determine java version from '9.0.1'

issue-resolved

#1

I experience an error similar to Could not determine java version from '9.0.1', just this time it seems to be a problem with Buildship instead of Gradle.

The error occurs in the “Gradle Tasks” tab in Eclipse. Running Gradle from the command line works as expected.

Here is the system setup:

  • Eclipse Oxygen.2 Release (4.7.2)
  • Buildship 2.1.2
  • Gradle Wrapper 4.4.1
  • OpenJDK 9.0.1+11

#2

The problem is solved by upgrading to Buildship 2.2.0.