Error while creating a new gradle based project on Eclipse Neon 4.6.1

issue-resolved
buildship
eclipse

(Jorge Decuir) #1

Hi, i have a problem with Eclipse Neon 4.6.1 and buildship tools when i try to create a new project. As soon as i select Wrapper(recommended) and click on finish it appears to be downloading the Gradle version 3.0 binaries, but after a moment the error in the screenshot appears and the project cannot be created! I hope you can help me!. Thanks in advance!


(Donát Csikós) #2

I just downloaded Eclipse with Buildship included and it seem to work correctly. But, there are other people who have the same problem. Can you please tell us:

  • What Buildship version do you use? (Menu > Eclipse > About Eclipse > Click on the ‘G’ icon)
  • What Java version your Eclipse runs on? (Menu > Eclipse > About Eclipse > installation preferences > Configuration > the line below the -vm entry)
  • Does it solve your problem if you upgrade to the latest 1.0.21 Buildship release? (Help > Eclipse Marketplace > Search for Buildship > Start the update).

(Stefan Oehme) #3

@donat I think this is an issue specifically with 1.0.17, which is included in Neon. We used a method that we removed in Gradle 3.1

This is fixed by upgrading to Buildship 1.0.21 (which is a drop-in-replacement)


(Donát Csikós) #4

True for Eclipse 4.6, but the reporter said Eclipse 4.6.1 into which we contribute Buildship 1.0.18. I used that one for the test.


(Stefan Oehme) #5

1.0.18 was before the fix too. The problem was fixed in 1.0.20


(Jorge Decuir) #6

Hi!, thanks for your answer! in fact i had to update the buildship, i tried to do that directly from installed plugins but with no luck. I had to do that from the Marketplace! now it is kinda working, the problem is that it downloads the 2.4 version of Gradle, but when i change to an specific version (say 3.1) it just doesn’t download.


(Jorge Decuir) #7

Ok, i could! sorry, guess my internet sucks a lot! thanks in advance for all the help! it worked like a charm!


(Jilles van Gurp) #8

I just ran into the same issue as jdecuirm, as would any eclipse user trying to use buildship currently.

The issue seems to be that the neon bundled version of buildship 1.0.18 is indeed not compatible with the latest gradle. Neon does not update it unless you force it to from the market place. This might need a bit more documenting as a I lost a good 45 minutes trying to figure out why a freshly created gradle plugin does not import into Neon.