Gradle process dont stop after test execution

test-tag

(Canberk) #1

I am using Gradle, TestNG and Restassured for my testing project. I have a build.gradle file which triggers a testng xml file to run tests.

test{
    useTestNG() {
        testLogging.showStandardStreams = true
        suites 'src/test/suite.xml'
    }
}

When I run my test on IntelliJ IDE, i can track execution progress. But when I run “gradle test” command, test execution progress is always “0 Tests completed”. In case I wait as long as my whole suites execution time, I can see that all tests are finished.(I create an HTML report at the end of my suite.) But command line is on hold with “0 tests completed”.

   Automated API Tests STANDARD_OUT
        Integration3rdPartyTests
    <=========----> 75% EXECUTING [2m 9s]
    > :test > 0 tests completed
    > :test > Executing test api.integrations...ClinicTests

I tried “gradle test --debug-jvm” and attached to the proccess, all tests are running fine. But it seems gradle is not aware that test started, in progress or done state.

Tests were running fine a few weeks later. I never run those test from commandline since 3 weeks, I only added some new dependency and a few new tests. That’s the only change.

Did anyone had the same problem?

I am using Gradle 4.8.1 , TestNG 6.14.3 and RestAssured 3.0.2 and working on MAC OSX