Gradle Artifactory Plugin jar missing from repository

Hi team,

In my gradle project we’re using Gradle 4.7 and “com.jfrog.artifactory” plugin, this plugin works fine until this morning.

When I do gradle build/clean I always get following errors:
java.lang.NoClassDefFoundError: org/gradle/api/publish/internal/PublicationArtifactSet

I did some lookup for this plugin’s source repository, seems like there’s no jar libraries from its gradle plugin site:

From this site I can only see one link “com.jfrog.artifactory.gradle.plugin”, following this link there’re only pom, md5, sha1 files for each version, but no jars.

Please can someone look into this problem? thanks a lot.


it turns out the latest gradle artifactory plugin (4.9.7) doesn’t work well.
using a previous version (4.9.6) works.

We started seeing this issue as well. We got around it by updating our Gradle version to 4.10.3

Yes, I got same problem using 3.5.1, or 4.7, and even 5.4

Hi Krisshen,

I am facing the same problem. For the URL that you provided, the jar is not present even in 4.9.6 version. Would like to know how were you able to resolve the issue then ?


im using gradle 4.7, and artifactory plugin version 4.9.6 works for me.

I think it may not be the url problem even though we cant see the jars. As I dig into my local gradle cached directories and I can see both 4.9.6 and 4.9.7 jars are already downloaded. while using the 4.9.7 I got this issue, so I tried to switch back to 4.9.6 and it worked!


Did anyone find a permanent solution to this, or did you all pin down the artifactory plugin to 4.9.6?

My challenge was moving from really old version of Gradle 2.x and 3.15, and with a stop at 4.10 - most projects could be built (but leftShift prevented moving to 5.x).