Problems with https://plugins.gradle.org/m2

plugins

(Wayne Gibson) #1

Hi,
I’m using Artifactory by Jfrog to as my repository my items, but also using it for cache external repositories and wanted to to use it for https://plugins.gradle.org/m2.

Unfortunately when I ask Artifactory it test the connect using https://plugins.gradle.org/m2, it fails with a 404 :frowning:
When I provide it https://plugins.gradle.org/ it passes, but then only seems to return a few items. Which seems to match the items that are displayed when you browse to https://plugins.gradle.org/.

If, in my Gradle script I add the repository for https://plugins.gradle.org/m2, the plugin comes down.
So it appears to be a issue with Artifactory and this repository…

Any ideas?

Thanks


(Mark Vieira) #2

You should point to https://plugins.gradle.org/m2. I believe Artifactory is returning that error as a result of the fact that its not strictly a Maven repo so whatever repository metadata Artifactory is looking for must be missing. Regardless, you can ignore the error and set it up as a remote repo anyway. When you attempt to resolve an actual artifact (pom.xml, jar, etc) the file will be found and cached as normal.


(René Groeschke) #3

I think the check in artifactory just fails because the plugin portal
doesn’t provide a landing page for the https://plugins.gradle.org/m2 and
returns a 404. This is a known issue and on a todo list to be solved in
the future.


(Stefán Freyr Stefánsson) #4

Any news on this? It’s a little annoying that IntelliJ keeps popping up with warnings about not being able to index the gradle plugin repository.


(James Justinic) #5

The issue mentioned in this thread was fixed months ago. A blank landing page that returns status code 200 for GET and HEAD requests was added at https://plugins.gradle.org/m2 so that Nexus and Artifactory properly detect the repository exists/responds via health checks/test buttons.

This doesn’t really have anything to do with whether or not an index is published. Everything I’ve seen on this topic suggests that the plugin portal is not well suited for generating an index as it is not just a typical maven repository. I would more expect JetBrains to fix the user experience when working with a repository that cannot be indexed, if they’re going to add features that work with known cases of this.


(Ezra Epstein) #6

The way I parse that reply is:

Our repo claims to be a maven repo, but doesn’t adhere to the standards of a maven repo since we don’t provide an index. So… hey the problem is with your tool that detects that our repo is borked - talk to your tool vendor and tell them to stop doing a good job!

In other words, it’s a strange reply. Why don’t the folks at gradle just… you know… fix their repo?


(Clinton Foster) #7

Regarding the Intellij warning, after all these months (years?) it’s still happening in Intellij 2017.1.2 (just released). Here’s a related JetBrains issue:

https://youtrack.jetbrains.com/issue/IDEA-148753

If Intellij is doing the right thing by reporting that the repository is missing its index, it would make sense to fix the root problem in the Gradle plugin m2 repository. Having said that, it’s pretty annoying there is no way to mute the warning pop-up in Intellij every time you load a project that references “https://plugins.gradle.org/m2/”.


(Daniel Lacasse) #8

If you dig a bit deeper in the issue you should fall onto this response which shows how to disable indexing of repositories in Intellij. We are unlikely to provide an index for the plugin portal at the present moment. I hope this helps resolve your question.


(Clinton Foster) #9

Thanks for the reply. Disabling the pop-up in Intellij per the referenced link worked. If you catch the pop-up in time right after opening the project there is also a menu for quickly accessing that setting.