Eclipse bug during import of gradle project (controlsfx-samples)

Hi, I have cloned a gradle project from bitbucket to my local machine and i am importing that project in eclipse and it’s showing the following error…

, I have chosen a different workspace and then tried to import their but got the same error again. I am new at gradle.
Thank you.

Looks like you’re hitting this issue. There’s a link to the bugzilla ticket in the thread.

As a workaround you could tweak some project names so they are unique

1 Like

Hi it seems the same issue but i have a different project structure, i have a root project with three subprojects and all these subprojects have their own build. I got through the answers ofthis but there is no solution.

Add the following to your root build.gradle and run gradle showDuplicates from command line

task showDuplicates << {
   def map = [:] 
   allprojects.each { proj ->
      def list = map[]
      if (!list) {
         list = [] 
         map[] = list 
      list << proj.buildscript.sourceFile
   map.each { k,  v ->
      if (v.size() > 1) println "Duplicate: $k $v"