CloudFlare isn't caching gradle distributions


(Micah Zoltu) #1

gradle.org is down at the moment (getting CloudFlare 522 error). One of the services CloudFlare offers is caching yet CloudFlare is saying

Website is offline No cached version of this page is available.

I strongly recommend going into CloudFlare and setting up caching on all static files, which includes the gradle distributions and the docs. At the moment, I am unable to build my project because of this outage and the only thing necessary to prevent this sort of outage of the static docs pages and the distribution files is spending a bit of time and configuring CloudFlare to do caching (especially during outages).

Things to cache:
https://services.gradle.org/distributions/*
https://docs.gradle.org/current/userguide/*


(Luke Daley) #2

Hi @Zoltu,

We do actually have the caching enabled, but it’s not very effective in our case. It’s never going to work for the distributions are they are far beyond the maximum size that CloudFlare will cache. So unfortunately, it’s not that simple. However, we are working on more redundancy in this area.


(Micah Zoltu) #3

Hmm, this suggests otherwise: https://support.cloudflare.com/hc/en-us/articles/200394750-What-s-the-maximum-file-size-CloudFlare-will-cache-

However, as an Engineer I understand that the answer in reality is often more complicated than the answer in a FAQ. So if you say that you are looking into solving this problem I’ll trust that it isn’t as simple as checking the right boxes in Cloud Flare. :slight_smile: