Buildship 2.2.2 is now available

buildship-release

(Donát Csikós) #1

Today we have published Buildship 2.2.2. This release contains the following changes:

  • #683 Adjust dark theme styling for wizards and preference pages
  • #702 Add option to use project hierarchy in Tasks view
  • #692 Adjust runtime classpath Gradle projects
  • #697 Don’t show WTP-related error when no Web Tools installed

Installation

Buildship 2.2.2 can be installed from the Eclipse Marketplace or by using the usual update sites.


(mauromol) #2

Hi Donat!
I suppose stable update site for Photon is:
http://download.eclipse.org/buildship/updates/e48/releases/2.x
(it’s not listed on the page you linked).
But what is that for 2018-09?
http://download.eclipse.org/buildship/updates/e49/releases/2.x
does not work.


(Neon Ngo) #3

I updated to Buildship 2.2.2 plugin on my Eclipse 2018-09 IDE (v4.9.0 , 20180917-1800 ) and I noticed that code completion/hints are not working when I am editing build.gradle files with the “Gradle Build Script Editor”.

E.g in dependencies { ... } section, I typed “impl” Ctrl+space and it does not give suggestion for “implementation”. I recall this working in 2.1.x. Any idea why it is no longer working?


(Sverre Moe) #4

Check for Updates, show there is BuildShip 2.2.2 available, but the update fails.
Running Eclipse 2018-09 (4.9)

n error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.gradleware.tooling.client,0.19.5.v20181001144510
No repository found containing: osgi.bundle,com.gradleware.tooling.model,0.19.5.v20181001144510
No repository found containing: osgi.bundle,com.gradleware.tooling.utils,0.19.5.v20181001144510
No repository found containing: osgi.bundle,org.eclipse.buildship.branding,2.2.2.v20181003-1021
No repository found containing: osgi.bundle,org.eclipse.buildship.core,2.2.2.v20181003-1021
No repository found containing: osgi.bundle,org.eclipse.buildship.stsmigration,2.2.2.v20181003-1021
No repository found containing: osgi.bundle,org.eclipse.buildship.ui,2.2.2.v20181003-1021
No repository found containing: osgi.bundle,org.gradle.toolingapi,4.10.2.v20181001144510
No repository found containing: org.eclipse.update.feature,org.eclipse.buildship,2.2.2.v20181003-1021


(Donát Csikós) #5

You are right, http://download.eclipse.org/buildship/updates/e48/milestones/2.x was not listed in the docs. I’ve fixed it.
2.2.2 from the e48 update sites works with 2018-09. I’ll adjust our infrastructure to produce e49 update sites shortly.


(Donát Csikós) #6

At the moment Buildship does not support code completion, only syntax highlighting.


(Donát Csikós) #7

This is a known issue, that most probably comes from the Eclipse platform. Please check https://github.com/eclipse/buildship/issues/488 for the workaround.


(Neon Ngo) #8

Oh, when is code completion when editing build.gradle planned? Is there an issue # for that?

FYI: according to the Announcing Buildship 2.0 blog back on Jan 11, 2017



Now, you can make changes to both projects with the benefit of complete IDE support: error markers, code completion, refactoring and more.


(mauromol) #9

Hi Donat,
still no official Update Site for e49?


(Donát Csikós) #10

There is a 2018-09 update site for Buildship 3.0 now: http://download.eclipse.org/buildship/updates/e49/snapshots/3.x/
FYI we are not planning to release more 2.x versions so now new update sites will be introduced.


(mauromol) #11

So is 2.2.2 officially not supporting 2018-09? Because the page at https://github.com/eclipse/buildship/blob/master/docs/user/Installation.md#installing-from-eclipseorg-update-site still offers no option to install the latest 2.2.2 over 2018-09.
The official 2018-09 update site still contains 2.2.1.
Above you said we can use Photon update site to install 2.2.2 on 2018-09, but if so, I think you should also notify it on that page.


(Donát Csikós) #12

2.2.2 does support 2018-09. If it didn’t we would publish another service release.

The installation page needs some care anyway, especially considering that Eclipse just changed to a rolling release. I’ll look into this soon.