Trying to import project that implicitly depends on another local project


(davidmichaelkarr) #1

So I’m trying to import the project defined at https://github.com/jenkinsci/git-plugin/releases/tag/git-3.3.0 . I unpacked the zip file locally, and then tried to import the Gradle project there.

I attempted the import and it gave me the following error dialog (“Synchronize Gradle projects with workspace failed”):
Loading Gradle project preview failed due to an error in the referenced Gradle build.
Could not fetch model of type ‘GradleBuild’ using Gradle distribution ‘https://services.gradle.org/distributions/gradle-3.5-bin.zip’.

A problem occurred configuring root project 'git-plugin-git-3.3.0'.
Could not resolve all dependencies for configuration ':classpath'.
Could not find org.jenkins-ci.tools:gradle-jpi-plugin:0.1-SNAPSHOT.

What’s curious is that this is apparently a fatal error, because this causes it to not import the project. I tried clicking OK on this dialog, and then clicking “Finish” on the “Import Gradle Project” dialog, but then it just brought back the “Synchronize failed” dialog again. I clicked OK on that dialog, but nothing else happened. No project was created.

I then tried finding the source code for the project it’s trying to reference as a dependency. I found that, and I was able to create a Gradle project from that. I then tried again to import the original project, but it went through the same path.

What can I do here?


(davidmichaelkarr) #2

Never mind. This turned out to be moot. I didn’t notice until now that the “build.gradle” in the project was 5 years old, and the pom.xml was 2 months old.