Trilead-ssh2-1.0.0-build221.jar disappeared from the plugin portal, failing the build


(Predrag Knezevic) #1

Hi,

Just noticed that trilead-ssh2-1.0.0-build221.jar does not exists anymore under the following url:

https://plugins.gradle.org/m2/com/trilead/trilead-ssh2/1.0.0-build221/trilead-ssh2-1.0.0-build221.jar

It did exist until yesterday, and from today my builds are failing.

Could somebody please restore it?

Thanks,

Predrag


(fabien) #2

Hi,

We face the same issue. The pom is still available but the jar is not.
This is our dependency chain leading to that module:
com.netflix.nebula:nebula-publishing-plugin:4.9.1(compile) -> com.netflix.nebula:gradle-info-plugin:3.1.0(compile) -> org.tmatesoft.svnkit:svnkit:1.8.+(compile,runtime) == dependency org.tmatesoft.svnkit:svnkit:1.8.15(runtime) -> com.trilead:trilead-ssh2:1.0.0-build221(compile,runtime)

Regards,
Fabien


(Tom Dunstan) #3

Hi all

I believe that is jar was actually hosted in JCenter. The plugin portal will redirect to JCenter for any dependencies that weren’t published directly to it.

It looks like the original publisher has deleted or moved it, or maybe unlinked their Bintray repo from JCenter.

Your best bet would be to get in contact with the author that had put it in there and try to get them to restore it. We would never have had it in the Plugin Portal directly.

Hope that helps

Tom


#4

We faced the same issue yesterday. Our “solution” was to upload POM and JARs to our internal Artifactory repository, sigh…


(Predrag Knezevic) #5

Did you need to update settings.gradle to point to your repo? Is there any way to do that without touching, say by using Gradle init.d scripts?


(Nathan Williams) #6

There’s been an issue in svnkit’s tracker since October. Whatever happened to jcenter was more recent, but the upstream problem seems to have existed for a while. Overriding the resolution strategy (I posted an example to the issue) is an option too.


(Alex White) #7

Thanks @nlwillia. I looked at your resolution strategy override and cannot get it to work. I’ve tried many forms. I’m using Gradle 3.3. I still get an error from gradle that the .jar is missing for 1.0.0-build221. Are there any gotchas with your workaround?


(Predrag Knezevic) #8

Put the following snippet in ~/.gradle/init.d/trilead.gradle - it works for me:

buildscript {
configurations.classpath {
    resolutionStrategy.eachDependency { DependencyResolveDetails details ->
        if (details.requested.group == 'com.trilead' && details.requested.name == 'trilead-ssh2' && details.requested.ve
            details.useVersion '1.0.0-build217'
        }
    }
}
}
}

(Nathan Williams) #9

Make sure you’re configuring the right configuration for your build. classpath as the next poster demonstrated is what you would use for a buildscript dependency, but if it’s something your application needs at runtime then you’d need to do it for compile or runtime.

If you happen to be resolving through Artifactory, then an alternative approach is to deploy an older copy of the missing jar under the newer coordinates to ext-release-local which should be found locally before it goes out to maven or jcenter.