The Gradle GUI is hanging after my tests finish


(Jon Austen) #1

This problem occurs for me whether I use Gradle 1.2, 1.3, or 1.4RC2 .

After my tests get to the end, and the last test is finished, the Gradle GUI will not accept any mouse input, appears to be locked up at either 11% or 88% , and doesn’t seem to ever finish (although I never waited more than 10 minutes).

This issue is new for me BUT I posted an issue previously that I completely resolved, where the command line Gradle and Eclipse gradle was hanging up at the end of my tests because I made the mistake of not cleaning up an object, but now that is no longer a problem. See post at: http://forums.gradle.org/gradle/topics/help_my_gradle_script_hangs_during_build_at_end_of_tests

My test project (that I am using to learn this Gradle stuff) is located here if you want to try it: https://github.com/djangofan/WebDriverTestingTemplate

I hope someone is able to look at it and help me. Just download the .zip archive of my project, unzip it, and run the “run_gradle.bat” file and choose “Gradle GUI” from the menu. -Jon


(Luke Daley) #2

I can’t use the GUI because there seems to be a hardcoded path somewhere:

it’s trying to move to the directory ‘C:\Eclipse32\workspace\WebDriverTestingTemplate’ on my machine, which doesn’t exist.

If I did get this working, then what do I do when the gui is up?


(Jon Austen) #3

Luke, thanks for trying. I looked through all of the .java code (and .xml config files) and I can’t find any hardcoded paths anywhere in my project. I am not sure how you are getting that error. I think there are enough debug statements to tell you what is wrong. Check the file called ‘junit.log’ that is generated by trying to run the tests.

Once, it runs, if you start the GUI from the root of the project (or via the batch file I included), there is a “favorite” saved in the GUI.

Otherwise, inside the .bat file there are examples of the arguments to pass to Gradle to run a project.

It is also possible, if you imported into Eclipse, that the .project file I provided is causing an issue, but I tried to be careful even in that case and the contents of that file don’t suggest a real problem. If so, then don’t use eclipse , and run it from the command line.


(Jon Austen) #4

Luke, I was able to reproduce the problem you were seeing. To fix, before you run as Gradle GUI, run as command line first (choose option #1 from the .bat menu). It will build all the project settings and arrange things properly, THEN you can run Gradle GUI and it will work for you.

Sorry, this is a Gradle wierdness that caused that and not a problem with my code AFAIK.

It’s a remnant of Gradle GUI settings remembering stuff from the system I checked-in from.


(Jon Austen) #5

Luke,

The problem I am having with Gradle GUI seems to be related to one particular computer system I have. I tried it on another system and didn’t have the problem any longer.

So, I will need to spend some time looking at it later.

That being the case, we can delete this thread or just consider it fixed for now. Thanks.


(Luke Daley) #6

Hi Jon,

Thanks for the update. I’ll close this for now.