Source Dependencies: Problems reading data from Binary store

Recently I’ve been trying to get source dependencies to work for our projects. After getting SSH to work for our private GitHub library repositories, I’m running into the following error during syncing. It clones the dependency sources correctly but it cannot sync or compile. I’ve also tried to get this working with public library projects on GitHub like Lottie-android, which gives the same issues. I’ve tried with Gradle version 5.4.2 up to 5.6.2. Plugin version 3.2.0 to 3.5.0. Using AS 3.5, but same issues when trying to build from command line.

Could not resolve all dependencies for configuration ':app:debugRuntimeClasspath'.
Problems reading data from Binary store in /private/var/folders/1s/9_kqj3dd4tl5ht_kpn9cxxp4755__y/T/gradle2221764272445267315.bin offset 47487 exists? true

I’m defining the repositories in settings.gradle like this:

sourceControl {
    gitRepository("") {

And in build.gradle like:

implementation (''){
    version {
        branch = 'master'

I’ve created a new release with tag on GitHub on the master branch. But I’m often seeing this message as well:

Git repository at ssh:// did not contain a project publishing the specified dependency.

I figured out what the problem was in my case. If anyone runs into the same issue then this is how to fix this step of the process.

I was missing the following line in the module build.gradle file of my library project (the project I was trying to use as a source dependency):

group = ''

Without this it just wouldn’t work. I now just placed this at the top of the build.gradle file in the library project, now I can actually declare my source dependency like:

implementation ''

Another problem though.
I’m guessing the Android Gradle plugin is not supporting this fully yet? I know this is outside of the scope of Gradle itself and this forum in general. But has anyone gotten this to work in Android Studio yet? I’ve tried upgrading to along with org.jetbrains.kotlin:kotlin-gradle-plugin:1.3.50 and Android Studio 3.6 Canary 12 build.

Could you provide information on how you have managed to get SSH to work with private repository for source dependencies?

It would be very helpful.