SonarRunner not honoring sonar.preview.excludePlugins property

I set the property sonar.preview.excludePlugins in the sonarProperties closure to tell the sonar runner to exclude the scmactivity and scmstats plugins. However, the sonar runner plugin still tries to run these plugins and seems to be ignoring this property. Is this a bug or a misconfiguration on my end?

can you post the snippet of your sonarRunner configuration here? do you set the analysis mode to “preview”? The following setting works for me:

sonarRunner {
    sonarProperties {
        property "sonar.analysis.mode", "preview"
        property "sonar.preview.excludePlugins", "scmactivity"

That worked for me, thanks