Sonar-runner doesn't run


(Sason Ohanian) #1

Hi! I’ve applied the sonar-runner plugin to the root project of my multi project build. When i run sonar-runner the task is never executed. Could it be because I have failing tests? I’m running it with --continue. If this is the case, can I somehow force the sonnarRunner to execute even when tests fail?


(Peter Niederwieser) #2

Currently, the best way to make sure that Sonar Runner runs despite previous failures is to either set ‘test.ignoreFailures = true’, or to undo the task dependencies set by the Sonar Runner plugin (‘tasks.sonarRunner.dependsOn = []’) and then run ‘gradle test sonarRunner --continue’. It’s a known issue and there is already a JIRA for it.


(Sason Ohanian) #3

Thanks! It seems to work. Though the sonarRunner seems to crash every time I run it. I get the following error:

13:06:12.001 INFO - Findbugs output report: C:\path\to\rootproject\gradleBuild\sonar\se.extenda.stdp bugs-result.xml 13:10:05.687 WARN - [JOURNAL_FLUSHER] WARNING Journal flush operation took 8,688ms last 8 cycles average is 1,086ms 13:16:32.984 ERROR - Unable to cancel semaphore updater in 1 second ----- End of the daemon log -----

FAILURE: Build failed with an exception.

  • What went wrong: Gradle build daemon disappeared unexpectedly (it may have been stopped, killed or may have crashed)

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. > Building > :sonarRunner

Any ideas on whats going on?


(Peter Niederwieser) #4

Any ideas on whats going on?

Not without more information, Perhaps the process is running out of memory. On a side note, I don’t recommend to use the Gradle daemon for running Sonar analysis (or CI jobs in general).