[Solved] Groovy integration tests not found in Jenkins

Hello all. I am having a terrible problem running groovy integration tests in Jenkins. Java integration tests run great locally and in Jenkins. The Groovy tests run fine locally but are not found in Jenkins.

This is msg is seen in the log. No errors are displayed.

[org.gradle.api.internal.file.collections.DirectoryFileTree] file or directory ‘/data/jenkins/lib/workspace/prod/service/simpleLayout/integration/build/classes/test’, not found

My repo directory structure is:

My gradle scripts are setup like so:
-integration.gradle (java integration tests)
-applicationTest.gradle (groovy integration tests)
build.gradle (applies the gradle scripts above)

The gradle script to run the groovy integration tests is:

buildscript {
    repositories {

apply plugin: 'groovy'

sourceSets {
    integration {
        groovy.srcDir file('src/integration/groovy')
        resources.srcDir file('src/integration/resources')

dependencies {
    testCompile group: 'com.job.service', name: 'service', version: '1.0.3+', changing: true
    testCompile group: 'junit', name: 'junit', version: '4.11'

    integrationCompile sourceSets.main.output
    integrationCompile configurations.testCompile
    integrationCompile sourceSets.test.output
    integrationCompile configurations.testRuntime

task appTest(type: Test) {
    useTestNG() {
        useDefaultListeners true
        includeGroups 'appTest'

    testClassesDir = sourceSets.integration.output.classesDir
    classpath = sourceSets.integration.runtimeClasspath
    //scanForTestClasses = true
    include "com/job/service/integration/AppTest.class"   //Tried lots of options here

    beforeTest { descriptor ->
        logger.lifecycle("Running test: ${descriptor}")

    reports.html.destination = "$buildDir/test-results"

./gradlew -v

Gradle 2.2.1

Build time: 2014-11-24 09:45:35 UTC
Build number: none
Revision: 6fcb59c06f43a4e6b1bcb401f7686a8601a1fb4a

Groovy: 2.3.6
Ant: Apache Ant™ version 1.9.3 compiled on December 23 2013
JVM: 1.7.0_79 (Oracle Corporation 24.79-b02)
OS: Mac OS X 10.10.5 x86_64

Let me know if more information is needed. Thanks in advance.