Problems with gradle buildship and cucumber


(Michael Whalen) #1

Hello. I am a new user to gradle. I’m running the the following buildship release:

 Buildship: Eclipse Plug-ins for Gradle	2.0.2.v20170420-0906	org.eclipse.buildship.feature.group	Eclipse Buildship

In Eclipse - Mars.

In examining the gradle settings, it appears that this uses gradle v3.5

When I try to include cucumber into my gradle file, I am getting an error in Eclipse, but not when I run the same script using gradlew from the command line. I am using buildship to build the gradlew script.

When I run ‘build’, the error that I’m seeing is:

The root cause appears to be

    Caused by: java.lang.IllegalStateException: Some build operations have not been marked as completed.

This occurs after the last test has been run as part of the build process.

As I said, when I run ‘build’ from the command line, everything runs correctly.

Any help would be appreciated! I’d like to use Cucumber in a course in the fall, and I’d like to use Eclipse as my primary tool for student projects. It is disappointing that I can’t seem to get them working together.