Play project runPlayBinary task logging problems


(Carsten Mjartan) #1

I’ve created a simple multi-module setup with one module using the play plugin. I also placed a logback.xml into the conf/ folder and added the neccessary logback dependencies to the play configuration.

If I run gradle runPlayBinary, the logback configuration is ignored and it falls back to the default logback configuration. When staging and running it in production mode, the config is working.

I also tried adding a logger-configurator.properties in the conf-Folder. The properties file is found, but any configured LoggerConfigurator class cannot be loaded in Dev Mode throwing a ClassNotFoundException.

Placing a breakpoint in DevServerStart.scala reveals, that the underlying classloader does not see “logback.xml”

Gradle Version: 3.1
Operating System and JVM version: Mac Os, Java 8

Startup log:

...
:service:runPlayBinary
No play.logger.configurator found: logging must be configured entirely by the application.
--- (Running the application, auto-reloading is enabled) ---

09:43:48.719 [main] DEBUG io.netty.util.internal.logging.InternalLoggerFactory - Using SLF4J as the default logging framework
09:43:48.722 [main] DEBUG io.netty.channel.MultithreadEventLoopGroup - -Dio.netty.eventLoopThreads: 16
09:43:48.736 [main] DEBUG io.netty.util.internal.PlatformDependent0 - java.nio.Buffer.address: available
...