Oxygen Buildship preferences

issue-resolved

(Vadim Lotarev) #1

Dear guru,

I’ve just installed Oxygen with Buildship bundled and do not see the way to specify path to Gradle in the preferences anymore (see screenshot attached). Re-installation of the Buildship did not help. Is that a planned behavior or there is something wrong with my installation?

Thanks,
Vadim


(Donát Csikós) #2

I don’t really understand, the workspace preferences UI hasn’t changed for quite a while now and looks just like how your screenshot shows. Perhaps you want to try the latest 2.1.0 snapshot, which introduces a new, hierarchical preference scheme for Gradle projects.


(Vadim Lotarev) #3

I remember that I was able to specify what installation of Gradle to use. How can I do that with the current version (2.0.2)?


(Donát Csikós) #4

You can use the Import Gradle Project wizard to reimport your project with a different distribution. You don’t have to delete the existing project before, the import algorithm will detect if a project is already in the workspace.


(Stefan Oehme) #5

In Buildship 2.1 (coming soon) you will also be able to set the default Gradle version used by Buildship in the workspace preferences.


(Vadim Lotarev) #6

I’ve just updated to 2.1 though is not able to see announced new Buildship preferences page. The following error is displayed when I try to select Gradle workspace preferences:

When OK is pressed corrupted preferences page is opened:

Could you please advice how to solve this problem (probably some settings should be reset or cleared …).

Thanks in advance,
Vadim


(Donát Csikós) #7

@vlotarev Can you try reimporting your project with the Gradle import wizard?


(Vadim Lotarev) #8

Well, either today’s update or Eclipse restart solved the problem. Everything is OK now. Thank you.


(Vadim Lotarev) #9

I am experiencing another problem with the latest version of Buildship. I have main project with several sub-projects (modules). When I try to run publish task from one of sub-projects Buildship always run publish of the root project. This worked correctly with previous version. Also it works correctly from the command line.