Non english name


(ruhp) #1

How I can add to war file with non english name (for example, russian)?

from (“src/main/reports”) {

into “reports”

}

Печать -> Х


(Peter Niederwieser) #2

Are you asking how to set the War’s filename to a non-English name?


(ruhp) #3

I wrote: add to war + code for copy files into war…


(Peter Niederwieser) #4

I know what you wrote, I just wasn’t sure what it means. I suppose you are talking about adding a file with a non-English filename to a War?


(ruhp) #5

See http://dfiles.ru/files/npa2rj0ac

In src\main\reports\ Тест.pdf In war reports\ӥ


(Peter Niederwieser) #6

You can either use unicode escape sequences in the build script (as you would do in a Java source file), or choose an appropriate file encoding (say utf-8) for the build script. In the latter case, it’s generally necessary to set the same file encoding for the Gradle JVM. (Depending on your JVM and platform, utf-8 may already be the default.) This can be done by passing ‘-Dfile.encoding=utf-8’ on the command line or via the ‘GRADLE_OPTS’ environment variable. Adding ‘systemProp.file.encoding=utf-8’ to ‘gradle.properties’ should also work, though probably only for builds that have the Gradle Daemon enabled.


(ruhp) #7

Thx, “systemProp.file.encoding=utf-8 to gradle.properties” works