No source folders when importing Gradle project with Buildship 3.1.2

I have been following some “getting started” tutorials for libGDX and I am having Gradle problems despite following the directions to the, which are probably outdated. I tried using IntelliJ and Eclipse.

Here is a new issue I am having. Right now I am trying to do something simple, which is import this project:

into Eclipse version: 2019-09 R (4.13.0) running Buildship 3.1.2. on a Mac.

After downloading the code and unzipping, I import “Existing Gradle Project” and choose the “libgdx-cookbook-master” as the project root directory. I then hit “Finish”.

At this point there are no source folders in the project, and no way that I can see for me to set source folders.

Sorry if this is a rather obvious issue.

The root directory in the git repository doesn’t contain build scripts (build.gradle, settings.gradle), only the environment and samples directories do. You should only import those projects.

I’ve tried to do just that and there seems to be a bigger problem. The projects require Gradle 2.2, which is really old. So old, that not even Buildship supports that. You should request (or try) updating the project to use at least Gradle 2.9 to be able to load the projects into the workspace.