--no-daemon not working?


(Nikita Salnikov-Tarnovski) #1

I am trying to run Gradle build as follows:

../gradlew --no-daemon classes -d

And I get the following

09:40:17.836 [DEBUG] [org.gradle.logging.internal.DefaultLoggingConfigurer] Finished configuring with level: DEBUG, configurers: [org.gradle.logging.internal.OutputEventRenderer@26832b87, org.gradle.logging.internal.logback.LogbackLoggingConfigurer@6d9ebfd1, org.gradle.logging.internal.JavaUtilLoggingConfigurer@51436a90]
09:40:18.079 [LIFECYCLE] [org.gradle.launcher.daemon.client.SingleUseDaemonClient] To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: http://gradle.org/docs/1.7/userguide/gradle_daemon.html.
09:40:18.091 [INFO] [org.gradle.launcher.daemon.client.DefaultDaemonConnector] Starting Gradle daemon
09:40:18.110 [DEBUG] [org.gradle.launcher.daemon.client.DefaultDaemonStarter] Using daemon opts: [-agentlib:jdwp=transport=dt_socket,address=8001,server=y,suspend=n, -Dfile.encoding=UTF-8]
09:40:18.112 [INFO] [org.gradle.launcher.daemon.client.DefaultDaemonStarter] Starting daemon process: workingDir = /Users/Nikem/.gradle/daemon/1.7, daemonArgs: [/Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Home/bin/java, -agentlib:jdwp=transport=dt_socket,address=8001,server=y,suspend=n, -Dfile.encoding=UTF-8, -cp, /Users/Nikem/.gradle/wrapper/dists/gradle-1.7-bin/2g3i7gan25uopmtc0lnjb1l9ff/gradle-1.7/lib/gradle-launcher-1.7.jar, org.gradle.launcher.daemon.bootstrap.GradleDaemon, 1.7, /Users/Nikem/.gradle/daemon, 120000, 02ff31ca-8370-4e48-b98f-7bbc905c4d81, -agentlib:jdwp=transport=dt_socket,address=8001,server=y,suspend=n, -Dfile.encoding=UTF-8]

I have no ~/.gradle/gradle.properties file. Why Gradle daemon is started with forked JVM and where these JVM settings can come from??


(Nikita Salnikov-Tarnovski) #2

Ok, that was my own fault. Found gradle.properties file in project dir :slight_smile: