Http:// can not be download. Please check

As title.

Works for me. Have you tried downloading the file via a web browser?

Yes. that’s the case. I’m able to download other version except 1.5.

Strange because I have just tried it (copy-pasted the link) and I can download it without problem. So, I believe the problem is not on the hosting side.

It redirects to this link:

But, when I access, it goes to, and I’m able to download it.

This IP seems to be a Chinese address, I think it is your ISP who redirects you for some reason.

If I use proxy. There will be an error: The following error was encountered while trying to retrieve the URL:

Access Denied.

Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

Your cache administrator is webmaster.

Works fine for me as well.

I’m sorry but I lack the knowledge to help you with this. However, I would first try to figure out why do you get redirected to these addresses. To me “” resolves to “”.

Works fine now. Thanks.