How can I set the artifactId in pom-default.xml?


(Steven Ford) #1

I get this error trying the publish to artifactory in Jenkins:

2012-05-28 08:36:22,209 [“http-bio-8081”-exec-413] [WARN ] (o.a.r.j.StoringRepoMixin:645) - IO error while trying to save resource libs-snapshot-local:lifeway/lifeway-rest/1.0.0-SNAPSHOT/lifeway-rest-1.0.0-20120528.134131-13.pom’’: The target deployment path ‘lifeway/lifeway-rest/1.0.0-SNAPSHOT/lifeway-rest-1.0.0-20120528.134131-13.pom’ does not match the POM’s expected path prefix ‘lifeway/workspace/1.0.0-SNAPSHOT’. Please verify your POM content for correctness and make sure the source path is a valid Maven repository root path.

it seems that the artifactId in pom-default.xml is using the project dir instead of the artifactId property. This works fine locally but Jenkins puts the job under a directory named workspace and that becomes my artifactId in the generated pom file. How can I force the artifcatId in the generated pom file?

gradle.properties:

version=1.0.0-SNAPSHOT nextVersion=1.0.1-SNAPSHOT

group=lifeway artifactId=lifeway-rest archivesBaseName=lifeway-rest


(Peter Niederwieser) #2

Gradle’s object model doesn’t have a top-level ‘artifactId’ property, so you are probably just introducing a new property that nobody uses (m9 or later will warn you about this). One way to control the artifact ID is to configure the project name in settings.gradle. (The artifact ID defaults to the project name which defaults to the project directory name.)


(Steven Ford) #3

Good to go! Thanks