Gradle error on Android Studio

android

(Marc de Ruijter) #1

On a fresh Linux (lubuntu) system i installed Android Studio and tried an ‘Hello World’ example.
On creation of the project i keep getting the following errors:

  1. Error:Process ‘command ‘/home/marc/Downloads/AndroidStudio/android-studio/jre/bin/java’’ finished with non-zero exit value 2
  2. Error running build: Module ‘MyFirstApp’ is not backed by gradle

I tried:

  • for more then a few hours to find a solution online (mainly stackoverflow)
  • change a AS compiler setting (heap size) as follows: Configure > Settings > Build, Execution, Deployment > Compiler> Change Build process heap size (Mbytes) to 1024 and Additional build process to VM Options to -Xmx512m
  • deleted the MyFirstApp project and started over again
  • read the AS idea.log
  • searched more on the internet
  • ‘run’ the app, which resulted in: “Error running build: Module ‘MyFirstApp’ is not backed by gradle”
  • restart AS and PC

Version info:
Ubuntu 16.04.1 LTS
Android Studio 2.2.1
Android plugin version: 2.2.1.
Gradle version 2.14.1
Java Version 8 Update 101

Now i am out of options. Please help me solve these grradle errors.
Thank you.