Gradle/Eclipse snafu

I am developing a plugin. I was using eclipse to write the plugin though not relying on Eclipse to build it. I check changes into central git stash, then pull them down on server and build there. It all worked. There was just one problem. When I tried to follow a link back into Gradle source, it refused to show it to me, and said that because I was using gradle as some sort of Library Package, I could not change the source path.

So I figured I would delete that and import the gradle-2.11 lib directory onto the classpath. That worked but didn’t help. Gradle classes were no longer recognized.

I don’t even remember how that folder came to be. I tried settting up 3 new Gradle projects one for each of the flavors of Gradle project that Eclipse allowed. I thought if I could see that folder I could set it back up and at least have the right stuff on the classpath. But none of these projects put this on the classpath.

I would like to at least get back to what I had. I can do without source files if I have to but am completely stumped how to do it.

Better yet would be a setup that also allowed me to see the gradle source.

My Eclipse version is Luna Service Release 2 (4.4.2)
My Gradle IDE eclipse plugin version is from Pivotal Software.