Gradle 7 change to configurations property compile

Tried the new Gradle 7, and got some errors when building

> Could not get unknown property 'compile' for configuration container of type org.gradle.api.internal.artifacts.configurations.DefaultConfigurationContainer.
jar {
    manifest {
            'Implementation-Version': project.version,
            'Implementation-Vendor': vendorName,
            'Specification-Version': project.version,
            'Specification-Vendor': vendorName,
            'Application-Name': applicationName,
            'Main-Class': project.application.mainClass,
            'Class-Path': configurations.compile.collect { it.getName() }.join(' '),
            'Built-By': userName,
            'Build-Time': buildDateTime,
            'Created-By': createdBy,
            'Permissions': 'all-permissions',
            'Codebase': '*'

I could not find anything in the Gradle 7 Release Not why configurations.compile no longer works.

Taking a look at the JavaDoc

I then tried to use instead configurations.compileClasspath which seems to work.
When did this change occour?

The use of compile has been discouraged in favor of implementation since 3.4: Gradle 3.4 Release Notes

It was officially deprecated per the normal release process and then finally removed in 7.0: