Gradle 1.5-rc-1 is now available for testing


(Luke Daley) #1

The Gradle team is pleased to announce that the release candidate for Gradle 1.5 is now available.

This release contains some important performance improvements, new capabilities for dependency resolution rules, new capabilities for the new Maven and Ivy publishing plugins, some new community contributed plugins and more.

For detailed information about Gradle 1.5, please see gradle.org/release-candidate.

Please try this release candidate with your projects and let us know if you encounter any issues.


(Jesper Skov) #2

I tried 1.5-rc-1 with this issue: http://issues.gradle.org/browse/GRADLE-2689 And I still get NPE in Gradle.

It worked in 1.0-milestone-3 (yes, I know, we’re lagging).

I would love if it could be fixed for 1.5. Or if you could point out why our build logic is broken :slight_smile:


(andrew.oberstar) #3

Now that RC-1 is out, I assume that means GRADLE-2415 definitely won’t be in 1.5 as originally planned?


(Luke Daley) #4

That’s correct unfortunately, it didn’t make it.