Getting error "deprecated in 7.0" when running 6.8.3

Hi there!
I am on Windows 10. I am getting an error on gradlew run after a successful build of the app I am trying to run. This app belongs to my company and I was not involved with developing it. So, I can’t change the code to fix anything. I am pasting the logs below, minus 90+ warnings that do not appear to be related. Here is what is happening:
I knew I needed to install gradle to run the app that I cloned the repo from github. So, I installed the most recent version on Gradle, 7.5. I ran the ‘gradlew build’ in the repo directory and the build was successful. When I ran ‘gradlew run’ to run the app, I got an error that it is using items deprecated in 7.0. So, I uninstalled Gradle 7.5 by deleting the directory from C:\Gradle\ and removing the environment variable.
I then went back to the Gradle site and downloaded and installed Gradle 6.9.2. I did the same process. Build was successful and I got the same error that the app is using something deprecated in 7.0.
I figured maybe this was because 6.9 was released after 7.0. So, I found the latest version before 7.0, 6.8.3. I uninstalled 6.9.2 with the same process and installed 6.8.3. Again, the build of my app was successful, but I got the message again that it could not run because of items in the app that are deprecated in 7.0.
Now, 6.8.3 definitely should not have anything from 7.0, since it was released before that time. Also, the Gradle User Manual that talks about CLI error messages for 6.8.3 lists the error in that version as something being deprecated in 5.0. This is not the error I am getting.
Can someone help me get rid of this error that says something is deprecated in 7.0 when I am running 6.8.3? I ran the ‘gradlew run --warning-mode all’ and got the following. This does not include a bunch of wanrings that do not appear to be relevant, like variables not being used and double asterisks being present that Gradle doesn’t seem to know what to do with.
Thanks so much for any help I can get. I just need this app to work.

Gradle logs below:

Configure project :
The CheckstyleExtension.setConfigDir() method has been deprecated. This is scheduled to be removed in Gradle 7.0. Please use the CheckstyleExtension.getConfigDirectory().set() method instead. See CheckstyleExtension - Gradle DSL Version 6.9 for more details.
at checkstyle_izjprn95pf5hvq050bia9w4t$_run_closure1.doCall(C:\Users\smitc7\Downloads[directories to repo]\gradle\checkstyle.gradle:6)
(Run with --stacktrace to get the full stack trace of this deprecation warning.)
The JavaApplication.setMainClassName(String) method has been deprecated. This is scheduled to be removed in Gradle 8.0. Use #getMainClass().set(…) instead. See JavaApplication - Gradle DSL Version 6.9 for more details.
at build_9zyhvxa0yy9oyet2bou0zstqz$_run_closure5.doCall(C:\Users\smitc7\Downloads\pega-logviewer-master\pega-logviewer-master\pega-logviewer\build.gradle:63)
(Run with --stacktrace to get the full stack trace of this deprecation warning.)
Inferred project: [app name and version]

Task :compileJava
… [a whole bunch of warnings about variables never used, double asterisks, etc. Nothing about anything deprecated.]

Note: C:\Users\smitc7\Downloads[directories to repo]\src\main\java\com[company name in directories]\systemstate\ uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
100 warnings

Task :run FAILED
Error: Could not find or load main class XXX_SET_USER_DIR_XXX

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:run’.
    Process ‘command ‘C:\Program Files\Eclipse Adoptium\jdk-8.0.332.9-hotspot\bin\java.exe’’ finished with non-zero exit value 1

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at

3 actionable tasks: 3 executed

Apologies. I had the wrong version of our app. I am fine now. The problem was not with Gradle at all.

Just a sidenote, it is absolutel irrelevant which Gradle version you have installed, or whether you actually have any Gradle version installed or not.
Each and every sane project should contain the four Gradle wrapper files.
As you said you run gradlew, it means the project contains the wrapper files.
The wrapper makes sure the correct version of Gradle for that build is automatically downloaded if necessary and used.
You only need a compatible version of Java installed, that’s all.

In your case is also does not say that something is deprecated in Gradle 7.
It says you use Gradle 6.9 and some things the build uses are deprecated and will be removed in Gradle 7, others in Gradle 8.